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Model 300 Overview
The Model 300 programmer supports JTAG programming of all Lattice devices that feature non-volatile configura-
tion elements. The Model 300 is used when a device must be programmed prior to being soldered onto a printed
circuit board.

Figure 1. The ISP Engineering Kit - Model 300

Device Support
All Lattice products that feature non-volatile configuration elements are supported. This includes devices with a VCC

of 1.2V, 1.8V, 2.5V, 3.3V and 5V.

Socket Adapters
Individual devices are supported via device/package-specific socket adapters, which interface to the 28-pin DIP on
the Model 300. For a complete list of supported devices and socket adapters, see the Socket Adapter list on the
Lattice web site at http://www.latticesemi.com/en/Products/DevelopmentBoardsAndKits/SocketAdaptersforDesk-
topProgramming.aspx.

http://www.latticesemi.com/en/Products/DevelopmentBoardsAndKits/SocketAdaptersforDesktopProgramming.aspx
http://www.latticesemi.com/en/Products/DevelopmentBoardsAndKits/SocketAdaptersforDesktopProgramming.aspx
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Connection to PC
The Model 300 programmer is shipped with both a PC Parallel port cable (HW-DLN-3C) and a USB port cable
(HW-USB-2A or HW-USB-2B). The cable connects between the appropriate port on your PC and the 2x5 connec-
tor on the Model 300. The programming operation is controlled with Lattice programming software, as described
below.

The orientation of the wires on the 2x5 connector is shown in Figure 2.

Figure 2. ispDOWNLOAD Cable In-System Programming Interface for the PC

When connecting to the Model 300 programmer JTAG connector, eight wires must be connected from the program-
ming cable: TCK, TMS, TDI, TDO, TRST, ispEN, Vcc and GND. It is sufficient to connect the programming cable
GND wire to a single JTAG connector GND pin: 2, 4 or 8. See UG48, ispDOWNLOAD Cables User’s Guide for the
full specifications of the cable and 10-pin connector.

Power Supply Support
The Model 300 programmer requires 9V DC at 1A minimum, to provide power for the programmer itself and for pro-
gramming the target device. A 9V power adapter is included with each kit. This power adapter accepts 110V to
220V inputs, and includes interchangeable physical plugs for use worldwide.

Programming Software Support
The Model 300 programmer is supported by both Diamond Programmer (version 3.0 and later), and the legacy
ispVM System (version 9.0.4d and later) software. Diamond Programmer is available as a stand-alone download or
bundled with Lattice DiamondTM Software, and is available from the Lattice website at
http://www.latticesemi.com/Products/DesignSoftwareAndIP/ProgrammingAndConfigurationSw/Programmer.aspx.
Lattice ispVM System is available from the Software archive section of the Lattice website at
http://www.latticesemi.com/Support/SoftwareArchive.aspx.

Special Features
With the exception of programmer power, the Model 300 programmer is controlled entirely by the programming
software. The user simply selects the device, programming adapter configuration and the target device VCC. LEDs
indicate the power status and the selected VCC level.

Installation Procedure
To install the Model 300 programming software, install the latest version of ispVM System software. If you are run-
ning Windows NT or Windows 2000, you will need to install the ISP NT driver. The ispVM installation will prompt
you to install the ISP NT driver.
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http://www.latticesemi.com/~/media/Documents/UserManuals/ispDOWNLOADCableUsersGuide.PDF
http://www.latticesemi.com/Products/DesignSoftwareAndIP/ProgrammingAndConfigurationSw/Programmer.aspx
http://www.latticesemi.com/Support/SoftwareArchive.aspx
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Operation Procedure
Setting Up the Hardware
Before you can use the Model 300 programmer, you must connect a download cable to your PC.

To set up your Model 300 programmer:

1. Turn on and boot up the PC. (Important: Do not boot or restart the PC when the Model 300 is on and has 
a device in the programming adapter socket. Its behavior is not ensured if it is on when the PC tests the 
parallel port).

2. With the Model 300 programmer in the power off position, connect the download cable between the PC 
parallel port and the Model 300 programmer.

3. Connect the power supply to a properly grounded AC outlet and to the AC plug at the rear of the Model 300 
programmer.

4. Make sure the PC has booted up completely, and then turn on the Model 300 programmer.

5. Place the device in the programming adapter socket. The 1.8V and PWR RDY LED indicators illuminate, 
indicating that the Model 300 is ready for programming. The LEDs are shown in Figure 3.

Figure 3. Model 300 LEDs
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Starting the Model 300 Programmer Software (Diamond Programmer)
To open the Model 300 programmer software:

1. Make sure the Model 300 programmer is connected and on.

2. The Model 300 Programmer is a stand-alone application. Launch the tool from the Windows Start menu:
Figure 4. Launching Model 300 Programmer from Windows Start Menu

The Model 300 user interface opens, as shown in Figure 5. The output box shows the results of the driver and
cable scan (LSC USB ispDOWNLOAD Cable Detected). The Status indicator in the Cable Settings box is Green.
Fix any issues before proceeding.

Figure 5. Model 300 Programmer User Interface
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Edit Device Family, Device and Device Package to select the appropriate settings. Verify the “Model 300 Adapter”
setting. Double click the Operation field to select the desired operation and Programming file:

Figure 6. Device Properties

Starting the Model 300 Programmer Software (ispVM System)
To open the Model 300 programmer software:

1. Make sure the Model 300 programmer is connected and on.

2. Start the ispVM System software, if it is not already running.

3. On the toolbar, click the Model 300 icon.

The Model 300 user interface opens, as shown in Figure 7. The status box at the bottom advises, “Please select a
device to start.”

Figure 7. Model 300 User Interface

M
300
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Programming a Device
1. If using a 28-pin socket adapter, insert the socket adapter into the 40-pin ZIF socket of the Model 300, 

shown in Figure 8. Make sure that the socket adapter is bottom-justified. (Note: If the socket adapter is not 
bottom-justified, the Model 300 will not read or program the device).

If using a Lattice socket adapter board, insert the socket adapter board pins into the appropriate connector 
on both sides of the 40-pin ZIF socket of the Model 300, shown in Figure 8. Make sure that all pins are 
inserted correctly.

Figure 8. Model 300 40-pin ZIF Socket and Socket Adapter Board Connectors

2. Using proper ESD handling procedures, place the device in the programming adapter socket, and ensure 
the correct alignment of the device. 

3. (ispVM) In the Model 300 main window, under Device, click Select, to open the Select Device dialog box. 
(Programmer) Edit Device Family, Device and Device Package to edit the settings. 

4. Select the appropriate device, device family and package, and then click OK to return to the main window.

In the Hardware Setting window, the Power and Voltage LED indicators illuminate, and the Status indicates 
Ready. The LED under Auto Detect illuminates and blinks. The user interface LED’s are shown in Figure 7. 
If the correct LED indicators do not illuminate, you may have selected the wrong device.

1.2V devices are treated as 3.3V devices by both the programmer and software. Lattice socket adapters for 
these devices contain a internal voltage regulator circuit to supply the appropriate programming voltage.

5. (ispVM) Under Data File, click Browse to select the JED (JEDEC) file. (Programmer) Select Edit > Device 
Properties to browse to and select the JED (JEDEC) file. Select the desired Device Operation.

6. Choose Project > Download (ispVM), Design > Program (Programmer) or click the GO button to down-
load the program to the device.

The VCC ON indicator turns red during the download process. It turns off when the operation is completed. 
The Status box (ispVM) or Output box (Programmer) indicates the progress of the operation, reports any 
errors, and shows whether the operation was successful or not.

7. When done, remove the device from the adapter socket.

8. Turn off the Model 300 programmer (optional).
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Hiding and Displaying Panels (ispVM)
You can save desktop space by shortening the main window and toggling the panel bar for the panel you want dis-
played, as shown in Figure 9.

Figure 9. Shortened Display Area

To shorten the display area and hide one or more panels:

1. Toggle the panel displays OFF by clicking on each panel bar and drag the bottom edge of the main window 
upward until it is the desired size (Figure 9).

2. Click the desired panel bar to toggle its display ON (Figure 10). 

Figure 10. Shortened Display Area - Hardware Setting Panel Toggled ON
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Selecting Project Settings
You can specify how the software will process the active chain configuration by using the Project Settings com-
mand.

To select project settings:

1. Choose Project > Project Settings (ispVM) or Edit > Settings > Programming (Programmer) to open 
the Project Settings dialog box.

2. Select the appropriate check boxes for the specifications you want to include.

3. Choose between TLR and RTI for the starting and stopping TAP states.

4. To change the TCK clock pulse for an optional JTAG signal, click Advanced (ispVM) or Use custom pulse 
width delay (Programmer), then type a different level in the TCK Clock pulse box.

5. Click OK.

Checking the Configuration Setup
To check the current configuration setup:

1. Choose Project > Configuration Setup (ispVM) or Design > Check Model300 Project (Programmer).

If the configuration check is successful, you will see a note to that effect in the Status box. If the configura-
tion check is unsuccessful, an error message will appear in a dialog box.

2. If the configuration check is unsuccessful, click OK, and then run Board Diagnostics to try to pinpoint the 
problem.

Running Diagnostics (ispVM only)
To run diagnostics:

1. Choose Project > Board Diagnostics to open the Board Diagnostics dialog box.

2. Compare the expected devices with those detected by the software. If they do not match, edit the chain 
configuration file and run the diagnostic again.

Changing File Locations
To change file locations:

1. Choose Options > File Locations (ispVM) or Edit > Settings > General (Programmer) to open the File 
Locations dialog box.

2. Browse to change the locations of the database, start and working directories, and log file name.

3. Select Clear Log File, if you would like the software to clear the contents of the log file each time you start 
the Model 300 programmer.

Repeating the Download (ispVM only)
Specify the number of times you would like the software to process a chain for download.

To specify download repetitions:

1. Choose Options > Repetitive Download to open the Repetitive Download dialog box.

2. Select the number of repetitions.

3. Select the number of errors you want to allow before the software stops the download process, and then 
click OK.
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Ordering Information

Description Ordering Part Number
China RoHS Environment-Friendly 

Use Period (EFUP)

Lattice Model 300 Desktop Programmer 
(RoHS-compliant) pDS4102-PM300N

Lattice Model 300 Desktop Programmer 
(Non-RoHS, replaced by RoHS-compliant version)

pDS4102-PM300
(Obsolete) 10
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Technical Support Assistance
e-mail: techsupport@latticesemi.com

Internet: www.latticesemi.com

Revision History
Date Version Change Summary

— — Previous Lattice releases.

March 2007 02.3 Added Ordering Information section.

October 2008 02.4 Updated product photo.

March 2009 02.5 Updated Ordering Information table.

June 2011 02.6 Updated figure: ispDOWNLOAD Cable In-System Programming Inter-
face for the PC.

September 2011 02.7 Updated Power Supply Support text section.

December 2013 02.8 Updated document to include USB cable options and Diamond Pro-
grammer support.

Updated corporate logo.

Updated Technical Support Assistance information.

mailto: techsupport@latticesemi.com
http://www.latticesemi.com
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