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product. Nor does it convey or imply any license under patent or other rights. Cypress products are not warranted nor
intended to be used for medical, life support, life saving, critical control or safety applications, unless pursuant to an express
written agreement with Cypress. Furthermore, Cypress does not authorize its products for use as critical components in life-
support systems where a malfunction or failure may reasonably be expected to result in significant injury to the user. The
inclusion of Cypress products in life-support systems application implies that the manufacturer assumes all risk of such use
and in doing so indemnifies Cypress against all charges. 

Any Source Code (software and/or firmware) is owned by Cypress Semiconductor Corporation (Cypress) and is protected by
and subject to worldwide patent protection (United States and foreign), United States copyright laws and international treaty
provisions. Cypress hereby grants to licensee a personal, non-exclusive, non-transferable license to copy, use, modify, create
derivative works of, and compile the Cypress Source Code and derivative works for the sole purpose of creating custom soft-
ware and or firmware in support of licensee product to be used only in conjunction with a Cypress integrated circuit as speci-
fied in the applicable agreement. Any reproduction, modification, translation, compilation, or representation of this Source
Code except as specified above is prohibited without the express written permission of Cypress. 

Disclaimer: CYPRESS MAKES NO WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, WITH REGARD TO THIS MATE-
RIAL, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
PARTICULAR PURPOSE. Cypress reserves the right to make changes without further notice to the materials described
herein. Cypress does not assume any liability arising out of the application or use of any product or circuit described herein.
Cypress does not authorize its products for use as critical components in life-support systems where a malfunction or failure
may reasonably be expected to result in significant injury to the user. The inclusion of Cypress’ product in a life-support sys-
tems application implies that the manufacturer assumes all risk of such use and in doing so indemnifies Cypress against all
charges. 

Use may be limited by and subject to the applicable Cypress software license agreement. 

PSoC Designer and CapSense Express are trademarks and PSoC is a registered trademark of Cypress Semiconductor
Corp. All other trademarks or registered trademarks referenced herein are property of the respective corporations.

Flash Code Protection

Cypress products meet the specifications contained in their particular Cypress PSoC Data Sheets. Cypress believes that its
family of PSoC products is one of the most secure families of its kind on the market today, regardless of how they are used.
There may be methods, unknown to Cypress, that can breach the code protection features. Any of these methods, to our
knowledge, would be dishonest and possibly illegal. Neither Cypress nor any other semiconductor manufacturer can guaran-
tee the security of their code. Code protection does not mean that we are guaranteeing the product as "unbreakable."

Cypress is willing to work with the customer who is concerned about the integrity of their code. Code protection is constantly
evolving. We at Cypress are committed to continuously improving the code protection features of our products.
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1. Introduction

1.1 Overview
The CY3218-CAPEXP3 Evaluation Kit is used for evaluation of the CapSense Express™ device.
This kit demonstrates the following features: CapSense buttons, LED drive, digital input, and I2C.
The CapSense Express device is configured via a system level project in PSoC Designer™. An 8-
SOIC package device is mounted on this board. The board is powered with an AAA battery. A boost
converter converts the input in the range of 1.1V to1.5V, to the device operating voltage of 3.3V. The
board can also be powered using an I2C USB bridge connected to the I2C header. 

1.2 Kit Contents
The CY3218-CAPEXP3 Evaluation Kit includes:
■ CY3218-CAPEXP3 CapSense Express Evaluation Board
■ Retractable USB Cable (A to Mini-B)
■ CY3240-I2USB Bridge Board
■ AAA Battery
■ 1 mm Acrylic Overlay 
■ Quick Start 
■ A Kit CD, which includes 

❐ PSoC Designer IDE
❐ PSoC Programmer
❐ I2C USB Bridge Software
❐ CapSense Express Data Sheets 
❐ Kit Release Notes 
❐ Kit User Guide
❐ Software Release Notes 
❐ Example Project Documentation
❐ Hardware Design Files

1.3 Default Jumper Settings
Jumper (J2) on CY3218-CAPEXP3 evaluation board configures the power setting for the board.
■ Default position for J2: Jumper on pin 1 and 2; this enables powering the board via I2CUSB 

Bridge.
■ To power the board via battery, remove the jumper at J2.
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1.4 Document Revision History 

1.5 Documentation Conventions 

Table 1-1.  Revision History

Revision
PDF 

Creation 
Date

Origin 
of 

Change
Description of Change

** 08/07/09 RKPM New kit guide for CapSense Express

Table 1-2.  Document Conventions for Guides

Convention Usage

Courier New
Displays file locations, user entered text, and source code:
C:\ ...cd\icc\

Italics Displays file names and reference documentation:
Read about the sourcefile.hex file in the PSoC Designer User Guide.

[Bracketed, Bold] Displays keyboard commands in procedures:
[Enter] or [Ctrl] [C]

File > Open Represents menu paths:
File > Open > New Project

Bold Displays commands, menu paths, and icon names in procedures:
Click the File icon and then click Open.

Times New Roman Displays an equation:
2 + 2 = 4

Text in gray boxes Describes cautions or unique functionality of the product.
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2. Getting Started

2.1 Hardware
The following figure illustrates the CY3218-CAPEXP3 evaluation board features.

Top View                              Bottom View

Status LEDs

CapSense Buttons Power Selection Jumper (J2)

Power LED CapSense Express 

AAA Battery Holder (J1)

I2C Header (J5)
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3. Installation

3.1 Install Hardware
The CY3218-CAPEXP3 evaluation kit is preprogrammed with demonstration firmware. These
instructions assume that your board is not reconfigured from the factory settings. If it has, follow the
instructions given in Create Project with CY3218-CAPEXP3 chapter on page 11 to configure the
board.
1. Unpack the CY3218-CAPEXP3 evaluation kit.
2. Insert the AAA battery into the battery holder.
3. Remove the jumper from J2 (back, left, and center of board).
4. Touch a button on the board. The respective status LED lights up.
5. Turn the board off by replacing the jumper on J2. Note that replacing the jumper disables battery 

operation.

Caution Do not touch the board anywhere other than the edges or on the buttons. Touching the
board in the wrong area can lead to unintended CapSense triggers causing unexpected behaviour. If
this happens, reset the power to the board. To do this, disconnect the battery supply by placing the
jumper on J2. To power the board again, remove the jumper from J2.

3.2 Install Software
To install, insert the kit CD/DVD into your PC's CD/DVD-ROM drive. If the installer does not start
automatically, start it manually by executing cyautorun.exe in the CD/DVD's root directory. Follow the
instructions on the screen to complete the installation.

Note If you have a previous installation of PSoC Designer or I2C USB Bridge software (older than
the version mentioned in the release notes), uninstall that version before reinstalling. To uninstall the
software, go to Start > Control Panel > Add or Remove Programs and click the Remove button
next to that software. Follow the instructions on the screen to complete the uninstallation. 
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4. Create Project with CY3218-CAPEXP3

4.1 Functional Description
The board consists of two CapSense buttons and two status LEDs associated with these CapSense
buttons. The status LEDs light up when the CapSense buttons are pressed.

4.2 Create New Project
1. Connect your computer to the CapSense test board I2C Connector (J5) using the CY3240-I2USB 

Bridge and a USB cable as shown in this figure.

2. Launch PSoC Designer.
3. Create a system level project by selecting File > New Project; name the project 'TwoCapSense-

Buttons' and save the design to a location of your choice on the computer. 
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Create Project with CY3218-CAPEXP3

4. Select View > All Driver Catalogs and then select the Inputs tab. Open the CapSense Express 
directory, right-click the 4 GPIO/CS Button Set Compact driver, and select Add to Design. The 
Add Input Driver window opens.

5. Name the driver ‘TwoButtons’ and click OK. The CapSense Express 4 GPIO/CS Button Set Com-
pact window opens.
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Create Project with CY3218-CAPEXP3

6. In the system level project, each CapSense button and LED require a separate driver. The 4 
GPIO/CS Button Set Compact driver is a special driver that allows you to configure all the buttons 
and LEDs in one interface. Each driver is listed in the Configure Local Parameters pane.
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4.3 Configure the Driver
By default, all driver types in the Configure Local Parameters pane are set to CapSense Input. To set
up the LEDs, set the Pin Type for drivers C2 and C3 to GPOutput and the Drive Mode to Strong
Drive. Set the Finger Threshold of C0 and C1 CapSense Inputs to 150. 

4.4 Configure Button and LED Behavior
1. In the Pin Specific Tuning pane, choose G2 from the Select Pin menu.

2. Click on the yellow box of the CapSense button you want to assign to LED G2. For LED output 
pin G2, select the CapSense button C0. A small line connects C0 to the purple OR box. To have 
the LED turn on when the button is pressed, click the little box to the right of the purple OR box. 
This changes the square to an invert symbol; this is needed as the LED is connected in current 
sink mode
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3. Repeat Step 1 and Step 2 for driver G3 according to the following table:

4. Enable I2C Drop The Sample filter in the CapSense Filtering Specific section.

5. Use the default CapSense Global Parameters for this application..

6. Configure I2C related parameters in Global Parameters as shown in the following figure.

4.5 Pin Assignment
1. Click the Pin Assignment (16-QFN) button in the top left. The User Pin Assignment window 

opens.

LED Input
G2 C0

G3 C1
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2. Assign each CapSense button and LED on the board to the pin annotated on the board. For 
example, the CapSense sensor on the extreme left is labeled GP1[1]. 

3. Drag each driver from the unassigned list to the appropriate pin.

Driver Pin 
Button1 (C0) GP1[1] 
Button2 (C1) GP1[0] 
Output1 (G2) GP0[1] 
Output2 (G3) GP0[0]
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4. Click OK to close the User Pin Assignment window.
5. Click Apply to board. Wait for the Configure through USB2IIC Bridge status window to appear 

and click OK.

6. Click OK to close the CapSense Express 4 GPIO/CS Button Set Compact: TwoButtons window.
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5. Tune CY3218-CAPEXP3

5.1 Monitor CapSense Signal
Follow these steps to monitor the CapSense signal.
1. Click Monitor to open the Monitor view.

2.  The Monitor Status indicator shows Connected.

3. Select the I2CUSB bridge power supply option.

4.  Right-click TwoButtons and select Show Tuner.

5. The Monitor Status indicator changes to Running and the CapSense Express window opens.
6. If your board is configured with another design, click Apply to board in the lower right of the 

CapSense Express window. When the Configure through USB2IIC Bridge status dialog appears, 
click OK. If your board is already configured with the correct design, the Apply to board button is 
grayed out.
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Tune CY3218-CAPEXP3

5.2 Tune Buttons
1. From the Select Pin menu, select C0. 

2. Touch the C0 button (left CapSense button). When the difference variable (represented as a red 
vertical bar) is higher than the finger threshold (represented as a dark blue horizontal bar, set to 
150), the touch registers as a hit. 

3. Place the overlay provided with the kit on the board (covering both buttons). 
4. Reset the device. To do this, select the powering option as External Power and then choose 

3.3V again. 
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Tune CY3218-CAPEXP3

5. Notice how the Difference Count value changes. The difference variable does not rise above the 
required finger threshold, and the button does not register a hit. The LEDs do not function as 
expected.

6. Reducing the IDAC increases the signal strength and vice versa. To tune this button with overlay, 
reduce the IDAC; apply the new setting for the board by hitting the Apply to Board button, Now 
touch the button and check the finger response; if it does not rise above the Finger Threshold 
repeat the process.

7. Repeat Step 1 to Step 6 for C1 CapSense button.
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8. Test the board by touching the CapSense buttons. The LEDs on board function according to the 
design. Also notice how the Pin Status and Latched Value indicators change based on touch.

9. Experiment with other materials such as plastic and wood or overlay used for your product.
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6. Technical References

When creating a new project, always use the CY3218-CAPEXP3 evaluation kit schematic and pin
assignment tables as specified in this section. If you do not follow this, your project may not behave
as planned.

6.1 CY3218-CAPEXP3 Evaluation Kit Schematic 
The schematic for CY3218-CAPEXP3 Evaluation Kit is available on the kit CD/DVD at
■ PDF file: <CD_root>\Hardware\REF_14697_REVSS_Schematic.pdf
■ DSN file: <CD_root>\Hardware\REF_14697_RevSS.dsn

6.2 CY3218-CAPEXP3 Board Layout 
Board files of CY3218-CAPEXP3 Evaluation Kit is available on the kit CD/DVD at
■ PDF file: <CD_root>\Hardware\PDCR_9460_REVSS_Layout.pdf
■ Gerber file: <CD_root>\Hardware\PDCR_9460_REVSS.zip

6.3 CY3218-CAPEXP3 Bill of Material (BOM)
BOM for CY3218-CAPEXP3 Evaluation Kit is available on the kit CD/DVD at
■ Excel file: <CD_root>\Hardware\121R_46000_REVSS_BOM.xls

6.4 CY3218-CAPEXP3 Pin Assignment
Pin Number Port Number Design Function

1 VSS Ground connection

2 I2C SCL I2C_Clock

3 I2C SDA I2C_Data

4 GP1[0] Cap_Button_2

5 GP1[1] Cap_Button_1

6 GP0[0] LED_2 (D3)

7 GP0[1] LED_1 (D2)

8 VDD Supply voltage (3.3V)
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7. Additional Resources

7.1 PSoC Data Sheets, Application Notes, and Technical Articles
Cypress provides a wealth of information about CapSense Express, and more is frequently added.
Many sample documents, schematics, layouts, guidelines, and other CapSense Express documents
are available on the CD and at www.cypress.com (except where indicated). 

To find documentation online:
■ Go to www.cypress.com.
■ Click on the Documentation link.
■ Select the type of documentation you are looking for from the Resource Types list.
■ Search for the document you require.

7.1.1 CapSense Express Data Sheets (available on www.cypress.com)

■ CY8C20110 Up to 10 IOs for touch sensing buttons, LEDs, and GPIOs
■ CY8C201A0 Up to 10 IOs for touch sensing buttons/sliders, LEDs, and GPIOs
■ CY8C20180 Up to 8 IOs for touch sensing buttons, LEDs, and GPIOs
■ CY8C20160 Up to 6 IOs for touch sensing buttons, LEDs, and GPIOs
■ CY8C20140 Up to 4 IOs for touch sensing buttons, LEDs, and GPIOs (16-Pin QFN/SOIC)
■ CY8C20142 Up to 4 IOs for touch sensing buttons, LEDs, and GPIOs (8-Pin SOIC)

7.1.2 CapSense Application Notes

■ AN44207, CapSense Express - API’s for Register Configuration

■ AN44208, CapSense Express - I2C Communication Timing Information
■ AN44209, CapSense Express Power and Sleep Considerations
■ AN42137, CapSense Express Software Tool
■ AN53490, CapSense Express™ - Design to Production
■ AN2292, Layout Guidelines for PSoC™ CapSense
■ AN2318, EMC Design Considerations for PSoC CapSense Applications
■ AN2394, CapSense Best Practices
■ AN2397, CapSense Data Viewing Tool
■ AN2403, Signal-to-Noise Ratio Requirement for CapSense Applications
■ AN14459, CapSense Device and Method Selection Guide
■ AN48755, Designing with CapSense Express™ 8 Pin SOIC Device
■ AN48430, CapSense Express™ - Noise Filtering Methods
■ AN47716, CapSense Express™ - Configuring PWM for LED Intensity Control

www.cypress.com
www.cypress.com
www.cypress.com
www.cypress.com
www.cypress.com
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