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PREFACE

Thank you for purchasing CrossCore® Embedded Studio (CCES) for 
Analog Devices, Inc. processors.

Purpose
The CrossCore Software Licensing Guide describes how to manage licenses 
for CCES software.

Intended Audience
The primary audience for this guide is anyone who is working with CCES, a 
licensed product from Analog Devices. It describes the product licensing 
options, installation, and activation. The guide also includes the 
troubleshooting and FAQ sections for licensing issues.

Manual Contents
The manual consists of:

• Chapter 1, “Licensing Overview” on page 1-1 
Describes the available CCES licenses and introduces licensing 
options. 

• Chapter 2, “Activating a License” on page 2-1
Details how to install and activate a CCES license.
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• Chapter 3, “Administering a Corporate Domain License” on 
page 3-1
Describes how to install and administrate a corporate CCES 
domain license.

• Appendix A, “Troubleshooting” on page A-1
Explains commonly encountered error messages and provides 
answers to frequently asked questions. 

• Appendix B, “Licensing Support” on page B-1
Describes how to contact Analog Devices regarding licensing 
issues.

What’s New in this Manual
This is the third revision of the CrossCore Software Licensing Guide. In this 
revision, some procedures have been modified to match the CCES online 
help style.

Technical Support
You can reach Analog Devices processors and DSP technical support in 
the following ways:

• Post your questions in the processors and DSP support community 
at EngineerZone®:
http://ez.analog.com/community/dsp

• Submit your questions to technical support directly at:
http://www.analog.com/support

• E-mail your questions about processors, DSPs, and tools develop-
ment software from CrossCore Embedded Studio or 
VisualDSP++®:

http://ez.analog.com/community/dsp
http://www.analog.com/support
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Choose Help > Email Support. This creates an e-mail to
processor.tools.support@analog.com and automatically attaches 
your CrossCore Embedded Studio or VisualDSP++ version infor-
mation and license.dat file.

• E-mail your questions about processors and processor applications 
to: 
processor.support@analog.com or
processor.china@analog.com (Greater China support)

• In the USA only, call 1-800-ANALOGD (1-800-262-5643)

• Contact your Analog Devices sales office or authorized distributor. 
Locate one at:
www.analog.com/adi-sales

• Send questions by mail to:
Processors and DSP Technical Support
Analog Devices, Inc.
Three Technology Way
P.O. Box 9106
Norwood, MA 02062-9106
USA

Product Information
Product information can be obtained from the Analog Devices Web site 
and CrossCore Embedded Studio online help system.

Analog Devices Web Site
The Analog Devices Web site, www.analog.com, provides information 
about a broad range of products—analog integrated circuits, amplifiers, 
converters, and digital signal processors.

http://www.analog.com
mailto:processor.tools.support@analog.com
mailto:processor.support@analog.com
mailto:processor.china@analog.com
http://www.analog.com/adi-sales 
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To access a complete technical library for each processor family, go to 
http://www.analog.com/processors/technical_library. The manuals 
selection opens a list of current manuals related to the product as well as a 
link to the previous revisions of the manuals. When locating your manual 
title, note a possible errata check mark next to the title that leads to the 
current correction report against the manual. 

Also note, MyAnalog.com is a free feature of the Analog Devices Web site 
that allows customization of a Web page to display only the latest infor-
mation about products you are interested in. You can choose to receive 
weekly e-mail notifications containing updates to the Web pages that meet 
your interests, including documentation errata against all manuals. MyAna-
log.com provides access to books, application notes, data sheets, code 
examples, and more.

Visit MyAnalog.com to sign up. If you are a registered user, just log on. 
Your user name is your e-mail address.

EngineerZone
EngineerZone is a technical support forum from Analog Devices. It allows 
you direct access to ADI technical support engineers. You can search 
FAQs and technical information to get quick answers to your embedded 
processing and DSP design questions.

Use EngineerZone to connect with other DSP developers who face similar 
design challenges. You can also use this open forum to share knowledge 
and collaborate with the ADI support team and your peers. Visit 
http://ez.analog.com to sign up. 

http://ez.analog.com
http://www.analog.com/processors/technical_library/ 
http://www.analog.com/subscriptions
http://www.analog.com/subscriptions
http://www.analog.com/subscriptions
http://www.analog.com/subscriptions
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Notation Conventions
Text conventions used in this manual are identified and described as 
follows.

Example Description

File > Close Titles in bold style reference sections indicate the location of an item 
within the CrossCore Embedded Studio environment’s menu system 
(for example, the Close command appears on the File menu).

{this | that} Alternative required items in syntax descriptions appear within curly 
brackets and separated by vertical bars; read the example as this or 
that. One or the other is required.

[this | that] Optional items in syntax descriptions appear within brackets and sep-
arated by vertical bars; read the example as an optional this or that.

[this,…] Optional item lists in syntax descriptions appear within brackets 
delimited by commas and terminated with an ellipsis; read the exam-
ple as an optional comma-separated list of this.

.SECTION Commands, directives, keywords, and feature names are in text with 
letter gothic font.

filename Non-keyword placeholders appear in text with italic style format.

Note: For correct operation, ...
A Note provides supplementary information on a related topic. In the 
online version of this book, the word Note appears instead of this 

symbol.

Caution: Incorrect device operation may result if ...
Caution: Device damage may result if ... 
A Caution identifies conditions or inappropriate usage of the product 
that could lead to undesirable results or product damage. In the online 
version of this book, the word Caution appears instead of this symbol.

Warning: Injury to device users may result if ... 
A Warning identifies conditions or inappropriate usage of the product 
that could lead to conditions that are potentially hazardous for devices 
users. In the online version of this book, the word Warning appears 
instead of this symbol.






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1 LICENSING OVERVIEW 

This chapter describes the licensing options available for CrossCore 
Embedded Studio (CCES) 1.0 users.

The following topics are covered: 

• Supported Operating Systems 

• System Requirements

• Note to VisualDSP++ Users

• Licensing Terminology

• License Types

• License Expiration and Subscription

• Licensing Options Summary

• Obtaining a License Serial Number

• Locating License Serial Numbers

• Getting a PC Ready for License Activation

If you have any questions related to CCES licenses or licensing, contact 
Technical Support.
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Supported Operating Systems 
CCES 1.0.2 is supported on the following operating systems:

• Windows® 8 Pro and Enterprise 

• Windows XP Professional SP3 (32-bit only)

• Windows Vista™ Business, Enterprise, or Ultimate SP2 (32-bit 
only)

• Windows 7 Professional, Enterprise, or Ultimate (32- and 64-bit)

 Windows Vista, Windows 7, and Windows 8 users may experience 
User Access Control (UAC) related errors if the software is 
installed into a protected location, such as Program Files or Pro-
gram Files (x86). We recommend installing the software in a 
non-UAC-protected location.

System Requirements
Verify that your PC has these minimum requirements for the CCES 1.0.x 
installation:

• 2 GHz single core processor

• 1 GB RAM

• 2 GB available disk space

• One open USB port

 A faster disk drive decreases the build time, especially for a large 
amount of source files.
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Note to VisualDSP++ Users
CrossCore Embedded Studio is a new Analog Devices product: the graph-
ical user environment and full development tool chain for digital signal 
processor applications. Although some aspects of CCES licensing will be 
familiar to VisualDSP++ users, the VisualDSP++ licenses themselves can-
not be used with CCES.

Licensing Terminology
License Installation

License installation is the process of entering valid license information 
into CCES. A license that has been entered into CCES but not activated 
immediately is said to be “installed”.

License Registration

License registration is the process during which a user informs Analog 
Devices that a license has been installed. License registration results in a 
validation code.

License Activation

License activation is the process of unlocking the functionality of a CCES 
product by registering your serial number with Analog Devices. Activation 
includes license installation, registration, and validation, all in one step.

License Validation

License validation is the process of entering an Analog Devices validation 
code into CCES. License validation completes the activation of an 
installed license.
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License Types
Toolchain Evaluation Licenses

A toolchain evaluation license provides 90 days of use on activation after 
which it expires and becomes permanently disabled.

If installed but not activated, this license allows 10 days of operation 
(grace or trial period) before it expires and becomes disabled. The license 
can be re-enabled by activation.

A toolchain evaluation license can be activated once on a particular 
machine.

Add-in Evaluation Licenses

Certain add-ins, such as Micrium µC/OS-III™ Real-Time Kernel for 
CrossCore Embedded Studio, also have an evaluation license. Once acti-
vated, this license lets you install the add-in. You can install versions of 
the add-in with release dates up to 90 days after activation (see License 
Expiration and Subscription).

An add-in evaluation license can be activated once on a particular 
machine.

Full Licenses

A full license does not expire once it has been activated.

Activation starts the license subscription, determining which product ver-
sions are enabled, based on release date (see License Expiration and 
Subscription). Subsequent full licenses, called maintenance licenses, can be 
purchased at a reduced cost to renew the subscription term for an addi-
tional year.
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If installed but not activated, a full toolchain license allows 10 days of 
operation before it expires and becomes disabled. The license can be 
re-enabled by activation.

A full toolchain license can be activated a limited number of times, which 
allows the user to move the installation to a different machine.

A full license for an add-in (a CCES software component) must be acti-
vated to allow the add-in to install. There is no grace period with this type 
of license.

License Expiration and Subscription
License expiration and subscription are related but distinct terms. License 
expiration refers to overall viability of the license. For example, a tool-
chain evaluation license provides 90 days of use after activation, then 
expires. A full license, on the other hand, does not expire after activation. 
See License Types for more information.

License subscription determines what product versions you can use with a 
license. The subscription starts when the license is activated and ends at 
the end of the subscription interval. Products released before the subscrip-
tion ends can be used with the license. Products released after a 
subscription ends cannot be used with the license.

A subscription example: A full license with a one year subscription interval 
is activated on June 1, 2013. This license can be used with products that 
have release dates up to and including June 1, 2014. To use products with 
release dates beyond this date, the user needs to activate a new license. 
Note that you continue to use products that were released before the sub-
scription ends even after the subscription itself has expired; the 
subscription determines whether or not newer versions of the product may 
be used.
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To renew a subscription, a maintenance license must be purchased and 
activated. Contact your Analog Devices sales office or authorized distribu-
tor. Locate one at:
www.analog.com/adi-sales.

License Locking Options
Node-Locked Licenses

Occasionally referred to as a single-user license or a per user license, 
a node-locked license is locked to the machine host ID of a specific host 
computer and provides a single license “seat”. Once installed, the product 
will run on that one computer only.

The machine host ID typically refers to the Media Access Control (MAC) 
address of the network card or motherboard. CCES uses MAC addresses 
as host IDs and supports the use of multiple MAC addresses in its licens-
ing scheme.

Corporate Domain Licenses

Corporate domain licenses lock to a network domain name, such as 
*.subdomain.yourcompany.com.

A license locks to one specific type of host ID. The license locking option 
cannot be changed.

http://www.analog.com/adi-sales 
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Licensing Options Summary
Licensing controls the operation and installation of the CCES 1.0 features 
and components. The licensing options are summarized in Table 1-1 and 
Table 1-2.

For example, an evaluation license for the CCES development tool chain 
EVAL-CCES-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX: 

• Has a serial number prefix of EVAL

• Allows use of the full development tool chain

• Expires 90 days after activation

Table 1-1. Licensing Options for CCES Tool Chain

Type Prefix Evaluation - EVAL Full - ADI

Applies to Full tool chain operation Full tool chain operation. 
(For add-ins, see Table 1-2.)

Expiration 90 days Permanent

Processor family Blackfin and SHARC Blackfin and SHARC

Locking options Node-locked Node-locked or corporate domain

Subscription None 1 year

Table 1-2. Licensing Options for CCES Add-ins

Type Prefix Evaluation - EVAL Full - ADI

Applies to µC/OS-III add-in installa-
tion

Add-ins installation.
(For tool chain operation, see Table 1-1.)

Expiration Permanent Permanent

Processor family Blackfin and SHARC Blackfin and SHARC

Locking options Node-locked Node-locked

Subscription 90 days 1 year
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• Allows use of Blackfin and SHARC processors

• Is node-locked to the MAC address (physical address of the net-
work card) of a specific computer

• Does not have a subscription interval

A full license for the CCES development tool chain, 
ADI-CCES-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX:

• Has a serial number prefix of ADI

• Is permanent once activated

• Allows use of Blackfin and SHARC processors

• Is node-locked to the MAC address of a specific computer or a cor-
porate network domain name

• Has a one-year subscription interval

A full license for an add-in, such as Micrium µC/OS-III 
ADI-[UCOS3]-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX:

• Has a serial number prefix of ADI

• Is permanent once activated

• Allows use of Blackfin and SHARC processors

• Is node-locked to the MAC address of a specific computer

• Has a one-year subscription interval
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Obtaining a License Serial Number
This section covers the following topics:

• Obtaining a Full License Serial Number

• Obtaining an Evaluation License Serial Number

 An evaluation license can be upgraded to a full license.

Obtaining a Full License Serial Number
A full license can be purchased from:

• Analog Devices, Inc. directly. Call (800) 262-5645 or 
781-937-2384 or go to the buy online facility at
http://www.analog.com/en/content/buy_online/fca.html

• Depending on your location, Analog Devices, Inc. local sales office 
or authorized distributor. To locate one, go to
http://www.analog.com/salesdir/continent.asp

A purchased copy of CCES is accompanied by the ADI serial number.

Obtaining an Evaluation License Serial Number
An evaluation license can be obtained from CrossCore Embedded Studio, 
which offers a tool chain evaluation license the first time it runs. CCES 
also offers an evaluation license for Micrium µC/OS-III the first time you 
install µC/OS-III.

An evaluation copy of CCES is accompanied by the EVAL serial number.

http://www.analog.com/en/content/buy_online/fca.html 
http://www.analog.com/salesdir/continent.asp 
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Locating License Serial Numbers
It is assumed that CCES software is installed, licensed, and running on 
your computer. 

To locate a CCES license serial number:

1. Choose Help > Manage Licenses. 

The Manage Licenses dialog box appears. The dialog box is used to 
look up information pertaining to CCES licenses installed on a 
computer and to perform various licensing tasks.

2. To copy a serial number of the license to the system clipboard:

a. Select the serial number.

b. Choose Copy serial number from the context menu.

3. To copy the entire license report to the system clipboard:

a. Click Report. The License Report dialog box appears.

b. Click Copy.

Tip: Choosing Help > Email Support automatically creates an e-mail 
message to processor.tools.support@analog.com, generates, and 
attaches the product information report to the message.

mailto:processor.tools.support@analog.com
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Getting a PC Ready for License 
Activation

License activation requires TCP/IP network (Internet) access. Ensure that 
your PC is connected to the Internet, and that firewall settings allow 
interaction with Analog Devices' licensing server.

If your license is node-locked, ensure your computer has a valid MAC 
address. On computers with Windows OS, you can view all current 
TCP/IP network configuration values by running the following command 
at the command prompt:

  ipconfig/all

 Docking or undocking a laptop may affect the MAC addresses 
availability.
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2 ACTIVATING A LICENSE 

The chapter describes the processes of installing a license string (serial num-
ber) into the CCES Integrated Development Environment (IDE) via the 
New License Wizard as well as activating the license, as defined in Licensing 
Terminology.

Refer to the CCES online help for reference information about the IDE 
components related to software installation and licensing.

The following topics are covered: 

• Starting the New License Wizard

• Selecting a License Type

• Entering a License Serial Number

• License Activation Methods

• Activating a License in One Step

• Delayed License Activation

• Validating a License
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Starting the New License Wizard
It is assumed that CCES software is installed. 

If CCES is run the first time or a new licensed add-in product is installed, 
to start the New License Wizard: 

1. Navigate to CrossCore Embedded Studio Environment via Win-
dows Start menu. A warning message appears.

2. Click Yes. 

If CCES is run the second time and thereafter, to start the New License 
Wizard:

• Choose Help > Manage Licenses > New. 

The New License Wizard appears. See Figure 2-1.
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Selecting a License Type
Select your CCES license type (described in License Types) on the Select 
License Type page of the New License Wizard (Figure 2-1). 

To select your license type:

1. It is assumed that the New License Wizard is launched (see Start-
ing the New License Wizard). 

Figure 2-1. New License Wizard: Select License Type Page
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2. Depending on whether you want to evaluate or activate your per-
manent/full license for the CCES product, do one of the following.

• If you would like to evaluate the CCES product (do not 
have a serial number for a full license):

I do not have a serial number and would like to evaluate 
the product is selected by default. Click Next. 
The Select license activation method page appears. See 
License Activation Methods for more information.

Note: You have bypassed the license installation step, while 
evaluating CCES software, for 90 days.

• If you have a serial number for a full license for the CCES 
product that you would like to activate:

1. Select I have a serial number that I would like to activate. 

2. Click Next.
The Enter your serial number page of the New License Wizard 
appears. See Figure 2-2.
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Entering a License Serial Number
Enter your CCES license string on the Enter your serial number page of 
the New License Wizard (Figure 2-2). 

To enter a license serial number:

1. It is assumed that the Enter your serial number page of the New 
License Wizard is open (see Selecting a License Type for how to). 

2. In Serial number, enter the number exactly as it appears, including 
dashes. 
Entering a valid serial number displays your computer’s host ID 
and enables the Next button.

3. Click Next. 
The Select license activation method appears. See License Activa-
tion Methods for more information.

You successfully entered the license serial number.

Figure 2-2. New License Wizard: Enter your serial number Page
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License Activation Methods
The following sections describe the process of license activation, as 
defined in Licensing Terminology.

A license can be activated immediately or after a trial period. The license 
activation can be performed:

• In one step if your PC is part of the TCP/IP network (Internet). 
This is the most convenient license activation method, described in 
Activating a License in One Step.

• In three steps if your PC is not part of the TCP/IP network. The 
second method also is referred to as delayed activation and 
described in Delayed License Activation.

In step 1, you install the license. For toolchain licenses, this pro-
vides access to the entire CCES tool chain until the specified 
license expiration date.

In step 2, you register the license. This results in the validation 
code sent back to you via e-mail.

In step 3, you validate the license (enter the validation code sent to 
you). This unlocks the trial period, making the license permanent.

 Corporate domain licenses and node-locked licenses are installed in 
the same manner, but a license file containing a corporate license 
can be distributed to multiple computers on the corporate domain. 
For more information about administering corporate domain 
licenses, refer to Administering a Corporate Domain License.
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Activating a License in One Step
If your computer has an Internet connection, to activate a license in one 
step is the most convenient method.

It is assumed that your PC is ready (see Getting a PC Ready for License 
Activation), and the license serial number is entered in the New License 
Wizard (see Entering a License Serial Number) for the one-step 
activation.

To activate the license in one step:

1. It is assumed that the Select license activation method page of the 
New License Wizard is open (see Entering a License Serial Num-
ber for how to). 

2. Install and activate a license on-line all in one step is selected by 
default. See Figure 2-3.

Figure 2-3. Activating a License in One Step
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a. If your computer has an Internet connection, click Next.
The Prepare for one-step license activation page appears.

b. If your computer does not have an Internet connection, or 
such a connection is isolated, select Install a temporary 
license and then register it via website and go to Delayed 
License Activation.

3. On the Prepare for one-step license activation page:

a. Fill in the form. The required fields are marked by an * 
(asterisk).

b. Click Next.
The Prepare for one-step license activation (continued) 
page appears.

4. On the Prepare for one-step license activation (continued) page, 
complete the form.

5. Click Finish.

The Your license has been successfully activated message 
(Figure 2-4) concludes the one-step license activation.

6. Click OK to return to the IDE.

Figure 2-4. Your license has been successfully activated Message 
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You successfully registered and activated your copy of the CCES 1.0 
software.

If you received an error message during this procedure, refer to Trouble-
shooting. 

Delayed License Activation
If you cannot activate your CCES license immediately, the delayed activa-
tion enables a customer to use the CCES tool chain for a specified trial 
period; the license activation date is delayed.

 You also can install add-in licenses through delayed activation. 
When these licenses are activated, they permit add-in installation.

Your PC must be ready (see Getting a PC Ready for License Activation), 
and the license serial number must be entered in the New License Wizard 
(see Entering a License Serial Number) for delayed license activation.

1. It is assumed that the Select license activation method page of the 
New License Wizard is open (see Entering a License Serial Num-
ber for how to).

2. If your computer does not have access to the Internet or Analog 
Devices’ licensing server, select Install a temporary license and 
then register it via website.

If your computer has access to the Internet and Analog Devices’ 
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licensing server, install and activate a license in one step. Keep the 
default selection, Install and activate a license on-line all in one 
step, and refer to Activating a License in One Step. See Figure 2-5.

3. Click Finish. The License Registration Instructions Web page 
appears. See Figure 2-6.

The License Registration Instructions page indicates that your 
license is installed but not registered. At this point, a CCES tool-
chain license provides 10 days of unrestricted toolchain use.

Figure 2-5. Delayed License Activation
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The page describes how to register your license, obtain a validation 
code, and complete activation of your license, with or without 
Internet access.

 Licenses for CCES add-ins install but are not valid until registered 
and activated.

4. Complete the registration process as instructed and submit the 
form. Analog Devices processes your information and sends a vali-
dation code in email. 

Figure 2-6. License Registration Instruction Page 
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Validating a License
Once you receive a validation code for your CCES product from Analog 
Devices via email, you can complete the delayed license activation process.

To permanently validate a license on a computer that is connected to the 
Internet:

1. It is assumed that the CrossCore Embedded Studio is installed and 
open. 

2. Choose Help > Manage Licenses.
The Manage Licenses dialog box appears.

3. Select the serial number of the license that you want to validate. 
The Validate command becomes enabled.

4. Click Validate. 
The Enter Validation Code dialog box appears. See Figure 2-6. 

5. In Validation code, enter the validation code sent to you.

Tip: Prevent typos by copying and pasting the license string.

Figure 2-7. Enter Validation Code Dialog Box 
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Activating a License

6. Click OK.
The successfully entered validation code results in a message indi-
cating that a permanent license has been created. 

7. Click OK.

The license serial number is added to the Manage Licenses dialog 
box. Note that the status icon next to the license serial number has 
changed.

Refer to the CCES online help for reference information about the IDE 
components related to software installation and licensing. 
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3 ADMINISTERING A 
CORPORATE DOMAIN 
LICENSE

This chapter describes how to create and install license files based on a 
corporate domain address.

Rather than locking to individual MAC (Ethernet) addresses, a corporate 
domain license locks to a network domain, such as *.subdomain.yourcom-
pany.com. A license file containing a corporate domain license can be 
copied to multiple computers on the domain, potentially reducing overall 
administrative overhead.

The following topics are covered: 

• Determining Your Corporate Domain

• Locating a Corporate Domain License

• Activating a Corporate License

• Distributing a License File
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Determining Your Corporate Domain
On computers with Windows operating system, view all current TCP/IP 
network configuration values by running the following command at the 
command prompt:
  ipconfig/all

The corporate domain is the value of the primary Domain Name System 
(DNS) suffix. The corporate domain license will be locked to this value, 
so all computers that use this license must have the same corporate 
domain value.

 If the primary DNS suffix is blank, the computer is not on a 
domain, and a corporate domain license cannot be used.

Locating a Corporate Domain License
The CCES installer creates a folder on each computer that holds license 
files. If you already installed a license and want to locate the license folder, 
follow the procedure in Locating License Serial Numbers. The complete 
path to the license file is at the beginning of the report.

On computers with Windows operating systems, the license folder usually 
resolves as:

• Windows XP: <system drive>:/Documents and Settings/All 
Users/Application Data/Analog Devices/CrossCore Embedded 

Studio

• Windows Vista, Windows 7, or Windows 8: <system 
drive>:/ProgramData/Analog Devices/CrossCore Embedded 

Studio

 On some computers, the license folder may be a hidden system 
folder. 
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Administering a Corporate Domain License

Activating a Corporate License
The process of activating a corporate domain license is similar to the pro-
cess of activating a node-locked license.

Follow the instructions in Activating a License in One Step or Delayed 
License Activation to activate your corporate license. 

 Validation codes for corporate domain licenses are sent via email 
regardless of the activation method.

Distributing a License File
To distribute a corporate domain license for the CrossCore Embedded 
Studio software:

1. It is assumed that CrossCore Embedded Studio software is installed 
on the target computers. 

2. Obtain the corporate domain license file.

Tip: Copy the license.dat from a computer on which it is already 
installed to every computer that is to be covered by the corporate 
domain license.

Tip: The License Report dialog box provides the location of the 
folder that contains the license file. 

3. On each computer in the network, do the following: 

a. (Optional) Back up and delete, or rename, the existing 
license file. 

b. Copy the corporate domain license file into the license 
folder created by the CrossCore Embedded Studio installer. 

CrossCore Embedded Studio should now run on the target computers.

../reference/adi_ref_license_report_dialog_box.htm
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A TROUBLESHOOTING

This chapter provides answers to common licensing problems and 
includes the following sections:

• Frequently Asked Questions (FAQs)

• Installation Warning Messages

• Frequently Asked Questions (FAQs)

If you still have questions related to CCES licenses or licensing after read-
ing this chapter, contact Technical Support or Licensing Support.

Frequently Asked Questions (FAQs)
Question: I have lost my serial number. Where can I find it, or how do I get 
a replacement?

Answer: You can locate already installed serial numbers in the CCES IDE: 
Help > Manage Licenses. Refer to “Locating License Serial Numbers” on 
page 1-10 for more information.

If you do not have CCES installed and licensed, e-mail Analog Devices 
with details of the person and company to whom the serial number was 
originally registered. For more information, refer to Technical Support or 
Licensing Support.
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Question: I’ve just installed a toolchain evaluation license using the “Install a 
temporary license and then register it via website” option of the New License 
Wizard. Now I get a message telling me that the license will expire in X days. 
I thought licenses were permanent?

Answer: When evaluation licenses are installed this way, they have an ini-
tial grace period. An evaluation license runs for 90 days after activation. In 
order to unlock the complete evaluation period, an evaluation license 
must be validated. 

Full toolchain licenses installed via the Install a temporary license and 
then register it via website option of the New License Wizard also have an 
initial grace period but become permanent when validated. Refer to 
“License Activation Methods” on page 2-6 for more details.

Question: I’ve just installed a full license for a CCES add-in using the Install 
a temporary license and then register it via website activation option of the 
New License Wizard. Now the status of the license shows as ‘Expired’. Doesn’t 
this license have a grace period? 

Answer: This type of license has no grace period: it must be validated to 
enable installation of its component. Refer to “License Types” on page 1-4 
for more details.

Question: What is the difference between license ‘expiration’ and license ‘sub-
scription expiration’? 

Answer: When a license is expired, it does not allow its products to be 
used at all. License subscription applies to licenses that are not expired and 
allows product use based on a product release date. See “Licensing Termi-
nology” on page 1-3 for more information.
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Troubleshooting

Question: How do I transfer my license to a new machine? 

Answer: Use the New License Wizard to activate your license on the new 
machine. If activation fails with a message “The license has already 
been registered the maximum number of allowed times”, request a reg-
istration history update via e-mail to 
processor.tools.registration@analog.com. Include the serial number(s) 
in question.

Question: How can I find out my registration history? That is, how do I find 
out which machines my serial number(s) are registered against?

Answer: To request an up-to-date registration history, send an e-mail with 
the serial number(s) in question to processor.tools.registration@ana-
log.com. 

Question: I’ve just installed a license using the Install a temporary license and 
then register it via website activation option of the New License Wizard. The 
validation code that was e-mailed to me is being rejected. What could be the 
problem?

Answer: Validation codes are valid for a particular serial number and 
host ID combination. If you are trying to activate your serial number on a 
second computer, you will have to register it on the new computer in 
order to receive the appropriate validation code.

For more information, refer to “License Activation Methods” on page 2-6.

Question: Where is the license.dat file on my computer?

Answer: There is only one license.dat file for all CCES installs on a 
computer, and it is located in the license folder. The full path to the 

mailto:processor.tools.registration@analog.com
mailto:processor.tools.registration@analog.com
mailto:processor.tools.registration@analog.com
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license file is given in the report generated by Help > Manage Licenses > 
Report or by Help > Email Support.

Note: The license folder may be a hidden system folder on some computers. 

Question: How do I install both a node-locked license and a corporate 
domain license on the same machine?

Answer: Licenses of all types can coexist on the same machine. Use the 
New License Wizard to activate both licenses. 

If you intend to install the corporate domain license on many machines, 
refer to “Determining Your Corporate Domain” on page 3-2. 

Installation Error Messages
This section describes some common error messages issued during license 
installation and validation.

Problem: A valid license could not be found.
Click Yes to install a license at this time. 
Click No to close CCES.

Solution: This message appears the first time CCES starts up or thereafter 
if there are no current licenses installed. Selecting Yes starts the New 
License Wizard.

Problem: A valid license could not be found.
Click Yes to manage your license(s) now.
Click No to close CCES. 
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Troubleshooting

Solution: This message appears if licenses have expired. Selecting Yes 
opens the Manage Licenses dialog box.

Problem: There was a problem installing the license for this serial number. 
Reason: Invalid license file. The license file may be obsolete, corrupted, miss-
ing, or read-only. 

Solution: This indicates a problem with the license.dat file. For exam-
ple, the license file is a VisualDSP++ license file that is incompatible with 
CCES. Check the contents of license.dat located in: 

• Windows XP. <system drive>:/Documents and Settings/All 
Users/Application Data/Analog Devices/CrossCore Embedded 

Studio

• Windows Vista, Windows 7, or Windows 8. <system 
drive>:/ProgramData/Analog Devices/CrossCore Embedded 

Studio

Also ensure that the file is not read-only. If the problem persists, contact 
Technical Support.

Problem: There was a problem installing the license for this serial number. 
Reason: A valid Host ID could not be found.

Solution: Host ID information for your system can be found through the 
Manage Licenses dialog box in the CCES IDE via Help > Manage 
Licenses > Report or Help > Email Support.

Licenses locked to an Ethernet (MAC) address require a physical TCP/IP 
network address to be available on the computer. This error can occur if 
there is no network card installed.
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Licenses locked to a disk serial number require a valid volume serial num-
ber. This error can occur if there is no C: drive installed, for example.

Corporate domain licenses require that the computer be on a domain. 
Refer to “Determining Your Corporate Domain” on page 3-2 for more 
information. 

Problem: There was a problem installing a license for this serial number. Rea-
son: The serial number has already been used and can be installed only once.

Solution: The serial number you are trying to install has been installed 
already on this computer. For further information, refer to “Licensing 
Terminology” on page 1-3.

Problem: There was a problem activating the license. Reason: There was an 
error during activation. This may be due to the following:

• network outage

• firewall blocking access to the ADI activation server

• maintenance of the ADI activation server

Solution: This can occur during one-step activation. First, open a web 
browser and confirm that you can open the URL http://www.analog.com 
without any network or firewall problems. Then try activating the license 
again in the New Licenser Wizard. If you were on the last page of 
one-step licensing activation when you closed the error dialog box, just 
click Finish again to complete activation.

If you still are unable to activate the license through one-step activation, 
on the Select license activation method page of the New License Wizard, 
select the Install a temporary license and then register it via website 

http://www.analog.com
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Troubleshooting

option. Follow the License Registration Instructions to register and vali-
date your license.

Problem: There was a problem registering the license. Reason: The license has 
already been registered the maximum number of allowed times. Details: Regis-
tration limit exceeded.

Solution: Full and evaluation licenses can be activated a limited number 
of times. Contact Technical Support with your current serial number, and 
we will help to activate your current license or issue a replacement license, 
depending on the circumstances.

Problem: The license was successfully installed, but there was a problem com-
pleting on-line validation. You can register and validate your license manually 
by selecting Help, Manage Licenses. 

Solution: The Manage Licenses dialog box lists the installed licenses. See 
“License Activation Methods” on page 2-6 for more information. 

Problem: The license file was successfully installed, but there was a problem 
opening the registration website.

Solution: This can occur due to a browser problem, for example. The 
Manage Licenses dialog box lists the installed licenses. See “License Acti-
vation Methods” on page 2-6 for more information.

Problem: There was a problem validating the license. Reason: The validation 
code is invalid. Please re-enter the code, ensuring that you type the code 
EXACTLY as you received it. It might be helpful to copy-and-paste your vali-
dation code rather than typing it manually.
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Solution: CCES detected that you entered an invalid validation code. 
Ensure that you have entered the correct validation code, exactly as given.

Validation codes are valid for a particular combination of serial number 
and host ID. If you are trying to install your serial number on a different 
computer than the one you initially registered, you need a new validation 
code. Refer to “License Types” on page 1-4 for details.

Installation Warning Messages
This section describes common warning messages issued during license 
installation and validation. These messages display in message boxes, dia-
log boxes, the Console view, and command prompt.

Warning (in message boxes): <serial number> expires in x days

-- or –<serial number> expires today.

Solution: If the given license has not yet been validated, it is in its grace 
period and will expire in x days (or today.) Refer to “Validating a License” 
on page 2-12 for details.

An evaluation license that has been activated also displays this message as it 
reaches the end of its life.

Warning (in dialog boxes): The Subscription Expiration dialog box appears 
at startup if any license subscriptions are due to expire soon. 

Solution: To prevent the re-display of messages for these licenses, select 
Do not show this message for these licenses again and click OK. 
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Troubleshooting

Warning (in the Console view or command prompt): 
[Informational ea1154] 
License to use this tool will expire in x days

Solution: The assembler has detected that your license will expire in x 
days. If you have an evaluation license or a full license, register and vali-
date it.
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B LICENSING SUPPORT

If you still are experiencing a problem after having tried to solve it using the 
information in this guide, contact Analog Devices Customer Support.

The chapter contains the following sections:

• E-Mail Support

• Telephone Support

• Information Required by Support

E-Mail Support
You can obtain support via e-mail as follows:

Registration Support:

Contact Registration Support if you have any problems with registering or 
validating your license serial number, or if you have lost your license serial 
number. Use the following e-mail address: 
processor.tools.registration@analog.com.

Processor Tools Support:

For all other queries regarding CCES licensing, contact Processor Tools 
Support. Use the following e-mail address: 
processor.tools.support@analog.com.

mailto:processor.tools.registration@analog.com
mailto:processor.tools.support@analog.com
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Tip: Choosing Help > Email Support automatically creates an e-mail mes-
sage to the above address, generates, and attaches the product information 
report to the message.

Telephone Support
In the USA only, licensing inquiries can be made to the following toll-free 
phone number: 1-800-ANALOGD (1-800-262-5643).

Information Required by Support
Before contacting Customer Support regarding a licensing issue, docu-
ment the problem.

Prepare to communicate the following information: 

• Software version provided by the Help > About CrossCore 
Embedded Studio dialog box

• License serial number(s) in question 

• Contents of license.dat (if available) 

• Screen captures of encountered error messages

Tip: Choosing Help > Email Support automatically creates an e-mail mes-
sage to processor.tools.support@analog.com, generates, and attaches 
the product information report to the message.

mailto:processor.tools.support@analog.com
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